using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?ms)(?<=AUTHOR=\{)\{.*?\}(?:[^{}]*)(?=\},$)";
string input = @"@inproceedings{baz,
AUTHOR={{Baz}, {S}. and Bar, {G}. and
Foo, {M}},
year={2013}
}
@inproceedings{baz,
AUTHOR={{%Baz%}, {S!}. and Bar, {^G^}. and
Foo, {<M>}},
year={2013}
}
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}