import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?ms)(?<=AUTHOR=\\{)\\{.*?\\}(?:[^\\{\\}]*)(?=\\},$)";
final String string = "@inproceedings{baz,\n"
+ " AUTHOR={{Baz}, {S}. and Bar, {G}. and\n"
+ " Foo, {M}},\n"
+ " year={2013}\n"
+ "}\n"
+ "@inproceedings{baz,\n"
+ " AUTHOR={{%Baz%}, {S!}. and Bar, {^G^}. and\n"
+ " Foo, {<M>}},\n"
+ " year={2013}\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}