$re = '/(?ms)(?<=AUTHOR=\{)\{.*?\}(?:[^{}]*)(?=\},$)/';
$str = '@inproceedings{baz,
AUTHOR={{Baz}, {S}. and Bar, {G}. and
Foo, {M}},
year={2013}
}
@inproceedings{baz,
AUTHOR={{%Baz%}, {S!}. and Bar, {^G^}. and
Foo, {<M>}},
year={2013}
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);