const regex = new RegExp('(?ms)(?<=AUTHOR=\\{)\\{.*?\\}(?:[^{}]*)(?=\\},$)', 'g')
const str = `@inproceedings{baz,
AUTHOR={{Baz}, {S}. and Bar, {G}. and
Foo, {M}},
year={2013}
}
@inproceedings{baz,
AUTHOR={{%Baz%}, {S!}. and Bar, {^G^}. and
Foo, {<M>}},
year={2013}
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}