re = /(?ms)(?<=AUTHOR=\{)\{.*?\}(?:[^{}]*)(?=\},$)/
str = '@inproceedings{baz,
AUTHOR={{Baz}, {S}. and Bar, {G}. and
Foo, {M}},
year={2013}
}
@inproceedings{baz,
AUTHOR={{%Baz%}, {S!}. and Bar, {^G^}. and
Foo, {<M>}},
year={2013}
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end