using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*?href=\""(.*?)\""(.*?)skip=\""true\"">";
string input = @"<a href=""mailforge.io"">
<a href=""google.dk"">
<a href=""facebook.com"" skip>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}