$re = '/<a.*?href=\"(.*?)\"(.*?)skip=\"true\">/';
$str = '<a href="mailforge.io">
<a href="google.dk">
<a href="facebook.com" skip>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);