import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a.*?href=\\\"(.*?)\\\"(.*?)skip=\\\"true\\\">";
final String string = "<a href=\"mailforge.io\">\n"
+ "<a href=\"google.dk\">\n"
+ "<a href=\"facebook.com\" skip>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}