re = /<a.*?href=\"(.*?)\"(.*?)skip=\"true\">/
str = '<a href="mailforge.io">
<a href="google.dk">
<a href="facebook.com" skip>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end