package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a.*?href=\"(.*?)\"(.*?)skip=\"true\">`)
var str = `<a href="mailforge.io">
<a href="google.dk">
<a href="facebook.com" skip>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}