import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(.)\\1{9}$)[2-9]\\d{9}$";
final String string = "0000000000\n"
+ "1111111111\n"
+ "2222222222\n"
+ "3333333333\n"
+ "4444444444\n"
+ "5555555555\n"
+ "6666666666\n"
+ "7777777777\n"
+ "8888888888\n"
+ "9999999999\n"
+ "0223231223\n"
+ "1234345545\n"
+ "9878712233";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}