$re = '/^(?!(.)\1{9}$)[2-9]\d{9}$/m';
$str = '0000000000
1111111111
2222222222
3333333333
4444444444
5555555555
6666666666
7777777777
8888888888
9999999999
0223231223
1234345545
9878712233';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);