import re
regex = re.compile(r"^(?!(.)\1{9}$)[2-9]\d{9}$", flags=re.MULTILINE)
test_str = ("0000000000\n"
"1111111111\n"
"2222222222\n"
"3333333333\n"
"4444444444\n"
"5555555555\n"
"6666666666\n"
"7777777777\n"
"8888888888\n"
"9999999999\n"
"0223231223\n"
"1234345545\n"
"9878712233")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")