using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"src=""\/\/(?:https?:\/\/)?.*\/(.*?)\?rel=\d*""";
string input = @"https://www.youtube.com/watch?v=6tBJO2KenCE";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}