package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`src="\/\/(?:https?:\/\/)?.*\/(.*?)\?rel=\d*"`)
var str = `https://www.youtube.com/watch?v=6tBJO2KenCE`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}