#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.p=\d*\&utm_source.*)"
Local $sString = "?p=10886&utm_source=newsletter&utm_medium=email&utm_term=https%3A%2F%2Fajp.com.au%2F%3Fp%3D10886&utm_content&utm_campaign=AJP+Daily+-+7+April+2016"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")