// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.p=\d*\&utm_source.*)").unwrap();
let string = "?p=10886&utm_source=newsletter&utm_medium=email&utm_term=https%3A%2F%2Fajp.com.au%2F%3Fp%3D10886&utm_content&utm_campaign=AJP+Daily+-+7+April+2016";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}