import re
regex = re.compile(r"(.p=\d*\&utm_source.*)")
test_str = "?p=10886&utm_source=newsletter&utm_medium=email&utm_term=https%3A%2F%2Fajp.com.au%2F%3Fp%3D10886&utm_content&utm_campaign=AJP+Daily+-+7+April+2016"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")