use strict;
my $str = '?p=10886&utm_source=newsletter&utm_medium=email&utm_term=https%3A%2F%2Fajp.com.au%2F%3Fp%3D10886&utm_content&utm_campaign=AJP+Daily+-+7+April+2016';
my $regex = qr/(.p=\d*\&utm_source.*)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}