import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.p=\\d*\\&utm_source.*)";
final String string = "?p=10886&utm_source=newsletter&utm_medium=email&utm_term=https%3A%2F%2Fajp.com.au%2F%3Fp%3D10886&utm_content&utm_campaign=AJP+Daily+-+7+April+2016";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}