#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(\d+(?:\.\d+)?)\s+(?:OK|FAIL)$"
Local $sString = "Ben" & @CRLF & _
"1x 1.32 1.32 OK" & @CRLF & _
"" & @CRLF & _
"Mark" & @CRLF & _
"3x 0.50 1.50 FAIL" & @CRLF & _
"" & @CRLF & _
"Johny" & @CRLF & _
"2x 1.20 2.40 OK" & @CRLF & _
"" & @CRLF & _
"Johny" & @CRLF & _
"2x 1.20 2222.454 OK" & @CRLF & _
"" & @CRLF & _
"Johny" & @CRLF & _
"2x 1.20 2222 FAIL"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")