re = /(\d+(?:\.\d+)?)\s+(?:OK|FAIL)$/mi
str = 'Ben
1x 1.32 1.32 OK
Mark
3x 0.50 1.50 FAIL
Johny
2x 1.20 2.40 OK
Johny
2x 1.20 2222.454 OK
Johny
2x 1.20 2222 FAIL'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end