import Foundation
let pattern = #"(\d+(?:\.\d+)?)\s+(?:OK|FAIL)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Ben
1x 1.32 1.32 OK
Mark
3x 0.50 1.50 FAIL
Johny
2x 1.20 2.40 OK
Johny
2x 1.20 2222.454 OK
Johny
2x 1.20 2222 FAIL
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)