// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(\d+(?:\.\d+)?)\s+(?:OK|FAIL)$").unwrap();
let string = "Ben
1x 1.32 1.32 OK
Mark
3x 0.50 1.50 FAIL
Johny
2x 1.20 2.40 OK
Johny
2x 1.20 2222.454 OK
Johny
2x 1.20 2222 FAIL";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}