package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(\d+(?:\.\d+)?)\s+(?:OK|FAIL)$`)
var str = `Ben
1x 1.32 1.32 OK
Mark
3x 0.50 1.50 FAIL
Johny
2x 1.20 2.40 OK
Johny
2x 1.20 2222.454 OK
Johny
2x 1.20 2222 FAIL`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}