using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Command:(.*)\[Player:(.*)\(Guid: (\d*)\) \(Account: (\d*)\) X: (.*) Y: (.*) Z: (.*) Map: (.*)";
string input = @"Command: .pi Myron [Player: Myron (Guid: 1) (Account: 6) X: 10349.504883 Y: -6378.253418 Z: 37.893562 Map: 530 (Outland) Area: 3431 (Sunstrider Isle) Zone: Eversong Woods Selected player: Myron (GUID: 1)]";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}