const regex = /Command:(.*)\[Player:(.*)\(Guid: (\d*)\) \(Account: (\d*)\) X: (.*) Y: (.*) Z: (.*) Map: (.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Command:(.*)\\[Player:(.*)\\(Guid: (\\d*)\\) \\(Account: (\\d*)\\) X: (.*) Y: (.*) Z: (.*) Map: (.*)', '')
const str = `Command: .pi Myron [Player: Myron (Guid: 1) (Account: 6) X: 10349.504883 Y: -6378.253418 Z: 37.893562 Map: 530 (Outland) Area: 3431 (Sunstrider Isle) Zone: Eversong Woods Selected player: Myron (GUID: 1)]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}