$re = '/Command:(.*)\[Player:(.*)\(Guid: (\d*)\) \(Account: (\d*)\) X: (.*) Y: (.*) Z: (.*) Map: (.*)/';
$str = 'Command: .pi Myron [Player: Myron (Guid: 1) (Account: 6) X: 10349.504883 Y: -6378.253418 Z: 37.893562 Map: 530 (Outland) Area: 3431 (Sunstrider Isle) Zone: Eversong Woods Selected player: Myron (GUID: 1)]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);