import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Command:(.*)\\[Player:(.*)\\(Guid: (\\d*)\\) \\(Account: (\\d*)\\) X: (.*) Y: (.*) Z: (.*) Map: (.*)";
final String string = "Command: .pi Myron [Player: Myron (Guid: 1) (Account: 6) X: 10349.504883 Y: -6378.253418 Z: 37.893562 Map: 530 (Outland) Area: 3431 (Sunstrider Isle) Zone: Eversong Woods Selected player: Myron (GUID: 1)]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}