import Foundation
let pattern = #"Command:(.*)\[Player:(.*)\(Guid: (\d*)\) \(Account: (\d*)\) X: (.*) Y: (.*) Z: (.*) Map: (.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Command: .pi Myron [Player: Myron (Guid: 1) (Account: 6) X: 10349.504883 Y: -6378.253418 Z: 37.893562 Map: 530 (Outland) Area: 3431 (Sunstrider Isle) Zone: Eversong Woods Selected player: Myron (GUID: 1)]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}