#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9a-zA-Z]+(?:, [0-9a-zA-Z]+){0,4}$"
Local $sString = "1, 2, 3," & @CRLF & _
"1, 2, 3, 4, 5," & @CRLF & _
"1, 4, 6" & @CRLF & _
"1, 2, 3, 4, 5, 6" & @CRLF & _
"2" & @CRLF & _
"data, hi," & @CRLF & _
"hello, something,bad"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")