using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9a-zA-Z]+(?:, [0-9a-zA-Z]+){0,4}$";
string input = @"1, 2, 3,
1, 2, 3, 4, 5,
1, 4, 6
1, 2, 3, 4, 5, 6
2
data, hi,
hello, something,bad";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}