const regex = /^[0-9a-zA-Z]+(?:, [0-9a-zA-Z]+){0,4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9a-zA-Z]+(?:, [0-9a-zA-Z]+){0,4}$', 'gm')
const str = `1, 2, 3,
1, 2, 3, 4, 5,
1, 4, 6
1, 2, 3, 4, 5, 6
2
data, hi,
hello, something,bad`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}