package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9a-zA-Z]+(?:, [0-9a-zA-Z]+){0,4}$`)
var str = `1, 2, 3,
1, 2, 3, 4, 5,
1, 4, 6
1, 2, 3, 4, 5, 6
2
data, hi,
hello, something,bad`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}