$re = '/^[0-9a-zA-Z]+(?:, [0-9a-zA-Z]+){0,4}$/m';
$str = '1, 2, 3,
1, 2, 3, 4, 5,
1, 4, 6
1, 2, 3, 4, 5, 6
2
data, hi,
hello, something,bad';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);