using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[^@]{3}|(?!^)\G)[^@]";
string substitution = @"$1*";
string input = @"nileshkemse@gmail.com";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}