$re = '/(^[^@]{3}|(?!^)\G)[^@]/';
$str = 'nileshkemse@gmail.com';
$subst = "$1*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;