re = /(^[^@]{3}|(?!^)\G)[^@]/
str = 'nileshkemse@gmail.com'
subst = '$1*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result