const regex = /(^[^@]{3}|(?!^)\G)[^@]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[^@]{3}|(?!^)\\G)[^@]', 'g')
const str = `nileshkemse@gmail.com`;
const subst = `$1*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);