use strict;
my $str = 'nileshkemse@gmail.com';
my $regex = qr/(^[^@]{3}|(?!^)\G)[^@]/p;
my $subst = '$1*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";