using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"out.*office";
string input = @"Just a quick update this month. I'm out of the office for a bit, but didn't want to miss connecting with all of you, especially ahead of ACE. :)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}