re = /out.*office/
str = 'Just a quick update this month. I\'m out of the office for a bit, but didn\'t want to miss connecting with all of you, especially ahead of ACE. :)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end