$re = '/out.*office/';
$str = 'Just a quick update this month. I\'m out of the office for a bit, but didn\'t want to miss connecting with all of you, especially ahead of ACE. :)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);