const regex = /out.*office/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('out.*office', '')
const str = `Just a quick update this month. I'm out of the office for a bit, but didn't want to miss connecting with all of you, especially ahead of ACE. :)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}