package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`out.*office`)
var str = `Just a quick update this month. I'm out of the office for a bit, but didn't want to miss connecting with all of you, especially ahead of ACE. :)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}