#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)a[^\S\n]*+\n?[^\S\n]*b"
Local $sString = "ab" & @CRLF & _
"a b" & @CRLF & _
"a " & @CRLF & _
" b" & @CRLF & _
"" & @CRLF & _
"# shouldn't match:" & @CRLF & _
"a" & @CRLF & _
"" & @CRLF & _
"b" & @CRLF & _
"a " & @CRLF & _
"" & @CRLF & _
" b"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")