// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)a[^\S\n]*+\n?[^\S\n]*b").unwrap();
let string = "ab
a b
a
b
# shouldn't match:
a
b
a
b";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}