import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "a[^\\S\\n]*+\\n?[^\\S\\n]*b";
final String string = "ab\n"
+ "a b\n"
+ "a \n"
+ " b\n\n"
+ "# shouldn't match:\n"
+ "a\n\n"
+ "b\n"
+ "a \n\n"
+ " b";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}