$re = '/a[^\S\n]*+\n?[^\S\n]*b/m';
$str = 'ab
a b
a
b
# shouldn\'t match:
a
b
a
b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);