package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)a[^\S\n]*+\n?[^\S\n]*b`)
var str = `ab
a b
a
b
# shouldn't match:
a
b
a
b`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}